Opened 10 years ago

Closed 10 years ago

#20 closed defect (fixed)

Warnings at first startup

Reported by: gregoa Owned by: stefan
Priority: normal Milestone: confclerk 0.5.4
Component: database Version: confclerk 0.5.1
Keywords: Cc:

Description (last modified by gregoa)

23:30 <gismo> gregoa: "Could not execute query QSqlError(-1, "Unable to fetch row", "No query")
23:30 <gismo> OrmException?: "No object exception"
23:30 <gismo> gregoa: and exit, after having pressed "About", the second line is reproducible simply pressing "About", the exit seems not :-(
23:31 <gregoa> gismo: 0.5.0 (testing) or 0.5.1 (unstable)
23:31 <gismo> gregoa: unstable ;-)
23:31 <gregoa> gismo: hm, I've seen the warning before but it always worked afterwards
23:32 <gregoa> gismo: will open an upstream ticket
23:32 <gismo> gregoa: yeah, now it works, so I do not know...
23:32 <gregoa> gismo: good :)

Change History (5)

comment:1 Changed 10 years ago by gregoa

Description: modified (diff)

comment:2 Changed 10 years ago by gregoa

gismo and me couldn't reproduce the crash later ...

comment:3 Changed 10 years ago by philipp

Milestone: confclerk 0.6.0confclerk 0.5.4

comment:4 Changed 10 years ago by stefan

Owner: set to stefan
Status: newassigned

comment:5 Changed 10 years ago by stefan

Resolution: fixed
Status: assignedclosed

This ticket contained two bugs:

The QSqlError was thrown during the parsing of source:trunk/src/create_tables.sql at source:trunk/src/sql/sqlengine.cpp@1378#L60. The piecewise parsing using QString.split(";") resulted in a final QString "\n" which resulted in the "No query" error.

The OrmException was raised as an unactive conference was not handled correctly in source:trunk/src/gui/mainwindow.cpp@1378#L158 and source:trunk/src/gui/mainwindow.cpp@1378#L190.

Note: See TracTickets for help on using tickets.