Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#38 closed defect (fixed)

[maemo] alarm goes off even after having been deactivated again

Reported by: philipp Owned by: philipp
Priority: normal Milestone: confclerk 0.6.0
Component: GUI Version: confclerk 0.5.4
Keywords: Cc:

Description (last modified by philipp)

reported by XTaran (this ticket originally was part of ticket #37):

alarm goes off even after having been deactivated again (in favourites tab).

Change History (5)

comment:1 Changed 10 years ago by philipp

Bug confirmed with Nokia N900.

comment:2 Changed 10 years ago by philipp

In a former version, the event ID was set as alarm message. This message is converted back to an event id in alarm.cpp when trying to delete an alarm. As the message was modified to show the event tile in r1359, deleting alarms does not work anymore.

However, reverting that commit would not help, not only because the ugly alarm message would come back again but because the event ID is not unique if multiple conferences are used.

comment:3 Changed 10 years ago by philipp

Description: modified (diff)
Owner: set to philipp
Status: newaccepted

Tried to fix this bug (together with gregoa) with r1429 but didn't test it.

comment:4 Changed 10 years ago by gregoa

Resolution: fixed
Status: acceptedclosed

comment:5 Changed 10 years ago by gregoa

Closed in r1429, cf. the commit message for details.

Note: See TracTickets for help on using tickets.