Opened 8 years ago

Closed 8 years ago

#42 closed defect (fixed)

fun with timezones

Reported by: gregoa Owned by:
Priority: important Milestone: confclerk 0.5.5
Component: database Version: confclerk 0.5.4
Keywords: Cc:

Description

somewhere the handling of UTC vs. localtime breaks, and events are shown a day too early. at least when entered manually as timestamps in the db.
orm functions?

Change History (5)

comment:1 Changed 8 years ago by philipp

The commit r1443 makes it at least better.

What remains to do:

  • After creating an event that starts before midnight but lasts after midnight, it creates two time groups when searching for the event. The problem is that QTime gets an overflow in EventModel::createTimeGroups().
  • Check what happens if an event starts a few minutes after midnight.

comment:2 Changed 8 years ago by gregoa

r1444: use QDateTime instead of QTime for calculations.

comment:3 Changed 8 years ago by philipp

Nice commit :-) r1444 solves some of the issues, but there seem to be more:

  • Before r1444, the minutes of the first time group were set to 0 so that the time groups started at full hours. Now the first time groups starts when the first event start but the documentation of the function still says that time groups start at full hours.
  • Strange grouping occurs when using the fosdem 2011 schedule and changing all start times that are 09:00 to 09:05.
Last edited 8 years ago by philipp (previous) (diff)

comment:4 Changed 8 years ago by philipp

Philipp's comments to r1444: r1448

comment:5 Changed 8 years ago by philipp

Resolution: fixed
Status: newclosed

Done in r1449.

Note: See TracTickets for help on using tickets.